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Unit I 

Introduction to Dreamweaver cs4,working with Dreamweaver websites. 

 

 

Introduction to Dreamweaver  

 

  It was first developed by Macromedia and then was acquired by Adobe in 2005. 

 Adobe creative suite a collection of various designing and publishing software , such 

as  Adobe Dreamweaver, Adobe Flash, Adobe Photoshop and Adobe InDesign. 

 Adobe suite help developers to perform various operations, such as Graphic 

Designing, Video Editing, publishing documents and designing and developing web 

applications. 

 Dreamweaver is powerful application software that helps in designing and developing 

the website. 

 Dreamweaver can use the various web technologies, such as Hypertext Markup 

Language (HTML),eXtensible Markup Language (XHTML),Cascading Style Sheets 

(CSS), and Java Script. 

 It provides a graphical editing environment to develop websites, web applications and 

web pages.  

 

Terms and Definitions   

 

Web page: 

A web page is a document file just like a text file. It can be edited with Notepad, 

WordPad, or any text editor. The main difference between a web page and a regular text file 

is that a web page is formatted with HTML tags. This HTML formatting is what you see 

when you switch your web page from the Design view to the Code view.    

Website: 

A website is a collection of web pages that are usually linked together with 

hyperlinks.   

 

Hyperlink or Link: 

A section of text or image that appears colored and/or underlined on a web page that, 

when clicked, will take you to another web page.   

HTML: 

A hypertext markup language consisting of tags. HTML tells the web browser how to 

display the content of your web page.  

  

Web server:  

 A computer or host for your website that makes your site publicly available on the 

web.  

 

Web browser:  



 an application or program that is installed on your computer that allows you to view 

web pages on the Internet (i.e. Internet Explorer, Mozilla Firefox, Google Chrome, Apple 

Safari).   

Index page: 

 The index page is the main page of your website, also called homepage. This is the 

first page that people will see when they visit your site. When you create the index page you 

must save it as index.html. Note: index.html must be spelled with all lower case letters.   

 

Web address: 

A URL (Uniform Resource Locator) is the text you type into the address bar of your 

web browser to access a web page. For example: http://www.cnn.com. 

.    

Template: 

Dreamweaver allows you to save a webpage as a template. You can add editable 

regions to the template. Then you create web pages from the template. When you edit the 

template and save the changes, Dreamweaver updates all of the pages that are created from 

the template. Anything that you add to the template appears on every web page that is created 

from that template. 

 

 

Exploring Dreamweaver 

  

 Dreamweaver is a full-featured Web Application development tool that helps you to 

create , modify and manage a website with the help of Dreamweaver interface. 

 It is a What You See Is What You Get (WYSIWYG) interface, which you can use to 

Add, View and Edit content in the webpage. 

 The Dreamweaver interface allows you to create HTML documents with help of tools 

and panels that assist you in building your website. 

 In Dreamweaver, you can work with HTML documents in three modes: 

 Design View 

 Code View 

 Split View 

 

 In the Design View, display the Dreamweaver editor in the web browser window. 

You can insert the elements such as tables, images and format or drag to place.   

 In the Code View, you can write the code in HTML,CSS and JavaScript, and other 

languages as needed by the browser to display the web page,. 

 In the Split View, the Document window divided in two sections: Code View and 

Design View. This mode allows you to view the changes in the Code View and 

Design View simultaneously.  

 

 

Features of Dreamweaver 

http://www.cnn.com/


 

The Dreamweaver application offers several new features that help you to create and design 

various interactive Web pages depending on your requirements. 

 

Enhanced Content Management Systems(CMS): 

These frameworks allow you to build websites directly in the design view. 

 

Enhanced CSS inspection: 

It allows you to gain information about the relationships between various elements of the 

webpage, such as margin, padding. 

 

New CSS Enable/Disable feature: 

Separates and temporally disables different CSS rules. 

 

New Site Setup Window: 

Allows you to quickly create a new website that does not consist of the scripting languages. 

 

Multiple Server Support: 

Allows you to work with different servers during the website setup. For example , two server 

setups are present simultaneously. 

 

Enhanced PHP code hinting: 

Provides you with the improvised support for PHP Syntax, such as completion of code and 

syntax checking. 

 

Enhanced CSS starter pages: 

Refers to the improvised CSS starter pages that let you work with the created Web Pages in a 

quick manner using the code provided by Dreamweaver. 

 

Subversions: 

Refers to the feature used for maintain and storing files and folders of previous versions for 

creates website at a subversion server, by tracking the changes when they are made. 

 

 

Advantage of Dreamweaver 

 

 A User-friendly interface 

 Support for different scripting languages. 

 Compatibility with different software. 

 

 

Introducing Dreamweaver Interface 

The Dreamweaver Interface contains various panels, bars and tools that are used to create and 

manipulate the documents.  



 

 

 

Figure 1: Dreamweaver’s Interfaces 

 

Components: 

 The Application bar 

 The Document Window 

 The Properties Inspector 

 The Panel Group  

The Application Bar 

 

The Application bar is located at the top of the application window. The bar contains the 

Dreamweaver logo, layout drop-down list, the extend Dreamweaver drop-down list, the site 

button, the Menu bar and workspace Switcher. 

 



 
 

Figure 1-2: Dreamweaver’s Application bar looks slightly different on Windows (top) and 

Macs (bottom). 

 

The Brief Description about the elements of the Application bar is as follows: 

 

The Dreamweaver Logo: Minimizes, Maximizes or closes a Dreamweaver document. It is 

located at the left side of the Application window and displays a system menu when you click 

it. 

 

The Layout drop-down list: Selects the Code and Design Views. It is located next the 

Dreamweaver logo and provides options to select the layout of the document. 

 

The Extend Dreamweaver drop-down list: Provides access to Extension manager, Web 

widgets and other Dreamweaver extensions. 

 

The Workspace Switcher: Toggles between the different workspace layout options. 

 

The CS Live Service button: Allows you to interact with server-side applications and 

explore CS Live service and helps in managing your Adobe BrowserLab account. 

 

The Menu bar: Contains various menus such as File, Edit, View and Insert to perform 

specific tasks. The following is a short description of the menus in the Menu bar: 

 The File Menu: Helps perform basic operations in a Dreamweaver 

document such as create, open, save, close and import a document. 

 The Edit Menu: Modifies an existing document. 

 The View Menu: Changes the view settings of a document such as zoom 

level and ruler guides. 

 The Insert Menu: Inserts images and tables in a web page. 

 The Format Menu: Formats the text and objects present on a Web Page. 



 The Site Menu: Creates new sites and manages existing ones. 

 The Window Menu: Performs various workspaces – related tasks, such as 

opening a panel, creating custom workspace and managing the workspace. 

 

 

The Document Window 

 The Document window represents the area where you design a Web Page or write the 

code for the Web Pages. 

 This window is located below the Application bar. 

 The document window contains the Document toolbar and the text editor. 

 The Document toolbar provides buttons that allow you to toggle between the code, 

Split and Design view of a document quickly. 

 

 

 
 

Figure 1-3: A document window like this represents each web page; here’s where you add 

text, graphics, and other objects as you build a page. The status bar at the bottom of the 

window provides some useful information. It shows you how quickly the page will download 

and the way the page encodes text—“encoding” refers to the characters the computer uses 

to represent text onscreen. 

 

 

 Title bar (Mac only). The title bar displays the name of the file on which you’re 

currently working. 



 Document tabs. When you have more than one web document open at a time, small 

tabs appear at the top of the document window—one for each open file. The name of 

the file appears in the tab; to switch to a file, just click its tab.  

 Related files bar. The related files bar lists all CSS (Cascading Style Sheets), 

JavaScript, and server-side programming pages (like PHP) the current web page uses. 

Web designers frequently work on these files, so the related files bar lets you quickly 

jump to and work on external style sheets, JavaScript, and other “helper” files. 

 Document toolbar. The Document toolbar lets you change the title of a page, switch 

between Design and Code views, jump to Live view (to see how the page looks and 

works in a web browser), preview the page in different web browsers, and change the 

look of the document window.  

 You may find two other toolbars, the Standard toolbar and Style Rendering 

toolbar, useful. The Standard toolbar is common on many Windows programs 

and includes buttons for frequent file and editing tasks like creating a new 

page, opening a page, saving one or all open documents, cutting, copying, 

pasting, and undoing and redoing actions. (Dreamweaver hides this toolbar 

until you summon it by choosing View→Toolbars→Standard.) The Style 

Rendering toolbar comes in handy when you work with CSS. You’ll learn 

how to use it on Previewing Media Styles in Dreamweaver. 

 Browser navigation toolbar. New in Dreamweaver CS5, this toolbar works with the 

program’s Live View feature. When you click the Live View button in the Document 

toolbar, Dreamweaver displays your page in a web browser built right into the 

program.  

 

 

The PROPERTIES Inspector 

 

 The PROPERTIES inspector is located at the bottom of the Document window and 

displays the properties such as image, text, table or frame of the selected object in the 

window.  

 If this panel does not appear on the Dreamweaver workspace, you can open it by 

selecting the Properties options form the window menu.  

 The content of the PROPERTIES inspector varies and depends on the selected 

element. 
 

 

 
Figure 1-4. If you don’t see the Property inspector, you can open it by choosing 

Window→Properties or pressing Ctrl+F3  

 

https://www.oreilly.com/library/view/dreamweaver-cs5-the/9781449381820/ch08s06.html#previewing_media_styles_in_dreamweaver


 Panel Group 

 A Panel refers to a collection of tools that can be used to perform various operations 

related to a single task.  

 These panel groups collapsed or expanded and docked or undocked.  

 The panels are displayed in the vertical orientation of the Dreamweaver workspace. 

 The Panel groups contain various panels such as INSERT, CSS STYLES, AP 

ELEMENTS, FILES  and ASSETS. 

 

Figure 1-5. Panel Group of Dreamweaver.  

Insert Panel 

 The Insert panel offers eight sets of objects, each available by selecting an option 

from the menu at the top of the panel. 

 The INSERT Panel contains buttons to insert different types of objects, such as 

images, tables and links in the document. 

 Each object has an HTML code that allows you to set the various properties for it 

according to you requirements. 

 



Figure 1-6. The Insert panel has many faces and, depending on how large your monitor is, 

several space-saving techniques for displaying it. Normally, the Insert panel displays the 

objects under each drop-down menu category in a single list with an icon and a name—for 

example, the picture of an envelope and the label “Email link” (top left). Unfortunately, this 

tall list takes up a lot of screen real estate. You can display the Insert panel’s buttons in a 

more compact way by hiding the labels. When you choose Hide Labels from the panel’s 

category menu (top right image), Dreamweaver displays the icons side by side in rows, 

taking up a lot less space (middle right image).  

Files Panel 

 The FILES Panel organizes the files for your Dreamweaver sites and provides the 

features needed to manage the files. 

 Using the FIELS panel, you can create new files and folders, open existing files ,copy, 

delete, rename and more files.  

 The FILES panel manages both local and remote sites. you can view and manage files 

in both sites, as well as transfer files from one site  to another. 

 

Figure 1-5. Panel Group of Dreamweaver.  

CSS styles Panel 

The CSS STYLES Panel displays the name related information of CSS, which is a formatting 

techniques that allows you to change the appearance of different items present on a Web 

page, such as text, heading and images. The CSS STYLES panel contains a toggle button at 

the top that allows you to switch between two modes, the All mode and the Current mode. 

In the All mode, the CSS STYLES panel displays two panes:  

 The All Rules pane, which appears on the top, and properties pane, which appears at 

the bottom.  

 The All Rules pane display a list of rules defines in the current document as well as 

all rules defines in style sheets attached to the current document. 



 The Properties pane allows you to edit CSS Properties for any selected rule in the All 

Rules pane. 

In the Current mode, the CSS STYLES panel displays the following three panes: 

Summery for selection: Displays the CSS Properties for the current selection in the 

document 

Rules: Displays the location of selected properties. 

Properties: Allows you to edit CSS properties for the rule applied to a selection.  

 

Figure 1-6: CSS Styles Panel of Dreamweaver.  

AP Elements Pane 

 The AP ELEMENTS panel manages the AP elements in a document.  

 An AP element in Dreamweaver is an HTML page element, normally a <div> tag that 

has absolute position assigned to it.  

 The AP ELEMENTS panel helps to prevent overlapping of AP elements. 

 It also allows you to change the visibility of AP elements, net or stack AP elements, 

or select one or more AP elements.  

 These elements are displays as a list of names, and the AP element that is created first 

appear at the top of the list. 

 

Figure 1-7: EP Elements Panel of Dreamweaver.  



Working with Dreamweaver websites 

 

Analyzing Static and Dynamic Websites 

Static websites refer to a collection of Web pages that are created using Hyper Text Markup 

Language(HTML).These websites are designed on a small scale and for the entities that 

provide static information, such as Wikipedia. Static websites are easy to develop, build test 

and publish on a web server; the websites are expensive to update and the content in the web 

pages a can become stagnant. 

 

In dynamic websites such as websites used for e-commerce content is refreshed very 

frequently. The dynamic websites gather information from different sources and create web 

pages dynamically on a Web pages dynamically on a web browser. These webpages are 

created using different programming languages such as Cascading Style Sheet(CSS), 

Extended Hypertext Markup Language(XHTML) or Hyper Text Preprocessor(PHP) Different 

combination programming languages serves helps automate the website.` 

File Naming Conventions 

 

When naming your files, always use lowercase letters and avoid using spaces.  For example, 

if building a page for course overviews it would be best to name the file 

Course_overview.html or courseoverview.html instead of Course Overview.html.   

The rules for file naming are: 

 

 Avoid uppercase letters  

 No spaces  

 Separate words with hyphens or underscores  

 Use shorter names 
 

 Main page is index.html  

 No special characters such as question marks, exclamation points, dollar signs, 
symbols, etc.  



 No punctuation  

 Do not use numbers as the initial character 
 

 

Create a Local Folder 

It is a good practice to create a local folder before you get started with Dreamweaver. This is 

your working directory. Dreamweaver refers to this folder as your local site. The local folder 

is usually a folder on your hard drive. 

To create a local folder: 

1. Right-click on your Desktop, and then click on New >> Folder. 

 

 

2.Give your new folder a name; something like “MyWesite.” 

 

Web Servers 

There are five items that you will need to know before you can publish web pages to a web 

server, even if it is your personal space on your home ISP account, such as AT&T, or 

Comcast. 

Items that you need to know to publish to a web server: 



Server Name: We will be using the Students server or the ksuweb server, so this will be 

studentweb.kennesaw.edu or ksuweb.kennesaw.edu. 

Connection protocol: SFTP. 

Username: This is your NetID. 

Password: This will be the password for your NetID or the password for your ksuweb 

account. Note that your ksuweb account password is different than your NetID password. 

Root directory: For the Students server and the ksuweb server, this will be html/. For some 

web servers, this may be public_html, or just public. 

The Dreamweaver Environment 

Dreamweaver is an application that helps you to create, edit, and manage web pages and 

websites. Dreamweaver provides you with a WYSIWYG (what you see is what you get) 

editing environment. In other words, while editing your page, it looks like it will when 

viewed by a web browser. It also lets you easily switch over to see and edit the HTML code 

of your web page if you so desire. Dreamweaver also provides a publishing tool that helps 

you easily manage your files both locally and on your web server. 

 

 

 

 

 

 

 

 

 

 

 



Defining a Site 

 

You must define a site for each new website you create. A site in Dreamweaver is a 

collection of files and folders (web pages, images, etc.) on your personal computer, and a link 

to your web space on the Internet. As you create and edit your web pages, you will be 

working on files on this local site. When your pages are finished and ready to be viewed on 

the Internet, Dreamweaver gives you the ability to Put” these files from your local site onto 

your web space (the remote site). 

 

Note: You should create a local folder for your web pages and have access to an 
account on a web server before you can define a Site. 

To define a Site: 

1. Start Dreamweaver and select Site from the Menu bar. 

2. Click on New Site… This will start the Site Setup wizard.  

 

 

 

 

3. Enter a name for your site in the Site Name field. The Site Name is used only for 
identifying the site within Dreamweaver so choose a name that will help you recognize 
the site later. 

 

4. Click on the folder icon  next to the Local Site Folder text box. (See Figure 6)  

 

 

 

 

 

 

 

 



5. Use the File dialog to navigate to your local folder, click on Open, and then click on 

Select. 

 

6. Verify that your local folder appears in the Local Site Folder text box.  

 

 

 

7. To be able to publish your files to the web, you must enter the remote server information. 

 

Note: You do not need to complete the next steps to begin working on your 
Dreamweaver site. You only need to define a remote server when you want to connect to 
the web and publish your pages. If you ready to begin working on your site, click on the 
Save button. 

 

To define the Remote Server: 

7.  Select Servers from the left side menu. 

 

 

 

 

 

8. Click on the + sign icon  at the bottom-left corner of the blank text area to add a new 

server.  

 

 

 

 

 

 

 

 

 

 



 

 

 

A pop-up dialog with the Basic tab selected appears. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

9. Provide a Server Name. The Server Name is only used within Dreamweaver so you 
should provide a name that is meaningful to you. 

 

10. Select SFTP from the Connect using: drop-down menu. SFTP stands for Secure 
File Transfer Protocol. 

 

 

 

 

 

 

 

 

 

 

 

 

 



11. Type in the SFTP Address. 

 

 The SFTP address for students is studentweb.kennesaw.edu.  

 The SFTP address for faculty and staff is ksuweb.kennesaw.edu. 

 

12. Enter your username and password. 

 

 The username and password for students is their NetID and their NetID 

password. 
 

 The username and password for faculty and staff is their NetID and 
their ksuweb password. 

 

Note: When you enter a password, Dreamweaver automatically checks the Save box 

to the right 

 

of the password field. Unchecking the option deletes your password. If you are a 
student using a computer in one of the campus labs, be sure to un- he k the Save” 
check box so that other 

 

students using the computer you are sitting at will not have access to your web 
space. If you are faculty/staff, and are using the computer in your office, you may 
want to leave this box checked. If you un-check this box, Dreamweaver will ask you 
for your password every time you try to access your site. 

 

Your password must be entered in order to test your connection. So enter it now. 
Later, after you have successfully tested your connection, make sure to uncheck the 
Save (password) option if you are on a lab computer. 

 

13. Enter html/ in the Root Directory text box. It is important that this be exactly as 
shown, or else it may not work properly. The Root Directory is the actual folder on 
the server where your site will reside. 

 

14. You can test the connection by clicking on the Test Connection button. 

 

14.1.If you get a message saying that Dreamweaver connected successfully, click OK. 

 

 

 

 



 

 

14.2. If you get an error message, click OK, and then repeat steps 10 through 14 to 
verify that the information was entered correctly. Note that the server 
information is case sensitive. If you still cannot successfully connect to the 
server, contact the KSU Service Desk for assistance. 

 

 

 

 

 

 

15. Enter your website address in the Web URL text box. 

 The Web URL for students is http://studentweb.kennesaw.edu/~yournetid  

 The Web URL for faculty and staff is http://ksuweb.kennesaw.edu/~yournetid  

 

 

 

 

 

 

 

 

 

 

 

16. Click on the Save button. 

 

 

 

 

 

 

 

http://studentweb.kennesaw.edu/~yournetid
http://ksuweb.kennesaw.edu/~yournetid


 

The server now appears on the Servers list. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

17. If you need to make changes to the server definition, you may click on the pencil icon 
below the text box. (See Figure 16)  

 

 

18. Click the Save button. 

The Manage Sites window appears. 

19. Click the Done button. 

Connecting to Server 

1. To see your site and all of the files that it contains, go to the Files panel. You should to 
see your new site in the left drop-down menu. The right drop-down menu allows you to 
toggle the local and remote server views, as well as offering a few more advanced 
views.  

 

 

 

 

 



 

The different view options are: 

 

 Local view: Shows the copies of the files for your website which are located 
on your local machine. 

 

 Remote view: Shows the copies of the files for your website which are stored on 
the Internet server that is providing access to your site to users. 

 

 Testing server: An advanced feature which would show the files which are being 
stored on a test server (We do not use this feature). 

 

 Repository view: Shows a listing of all the files in the repository when working with 
Subversion, a versioning control system. (We do not use this feature). 

 

2. To see your remote files, click on the Connect to Server button  in the Files panel 

toolbar, and then select Remote server from the views drop-down menu.  

 

Note: if you see an index.html file on the remote site, it is just a placeholder. You will be 
replacing it with your own custom home page. 

 

3.  Select Local view from the views drop-down menu to display the local site again. 

 

Note: If you are working at a computer that does not have the local folder with your 
website files in it, you can create a local folder, define the site on this computer, and then 
download the files from your account on the server, by clicking on the Get arrow.  

 

 

 

 

 

You are now ready to design your web pages. 

 
 
 
 
 
 
 

 



 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 


